Talk:SD card compatibility



An odd compatibility issue

I bought a new 1GB SD card (PNY technologies brand), inserted it into the GP2X, and tried connecting over USB. The result was the message "High Speed device @ 2 (0x5B200000): ... Unknown device (did not respond to inquiry)" as seen by USB Prober (OSX). [i]However[/i], after buying a card reader and using it to transfer a file onto the card without (as far as I can tell) actually formatting the card, all is well and it now shows up properly on USB. Very odd. --Araneidae 16:07, 26 November 2005 (GMT)

The degree to which the card is recognised seems to by very sensitive to how the card is formatted. I have found that a validly formatted card (recognised by my iBook) can be in one of the following states as far as the GP2X is concerned:

  • Card is readable by the GP2X, but the USB connection is not completed.
In this case the "unknown device" message logged above is seen. This was the initial state when I first inserted my SD card.
  • Card is readable, USB connection is established, but Firmware Upgrade does not happen.
This state seems to be seen by many people. I was briefly in this state yesterday with my SD card, but now it is back to the state above.
  • Card is unreadable by the GP2X.
Easily done.
  • The GP2X locks up during bootup when card is installed.
This also seems to happen easily.
  • The card is readable, USB connection is established, and the firmware upgrade completes.
This is the unattainable holy grail.

If somebody can post up a link to the grim and gory details of SD card formatting and the right tools to view and edit it, I'd be very grateful. Then I might be able to bottom this problem out. Araneidae 11:12, 27 November 2005 (GMT)

Maybe this brings some light: Setting the partition type to 0x0B (W95 Fat32) instead af 0x01 (Fat12) worked for my 16MB card (Sandisk). mcr42 11:36, 03 March 2006 (GMT+1)

A card not on the list

I bought some 2GB Corsair SD cards. They don't seem to have the same capacity as Sandisk 2GB cards, but they do work for firmware upgrades. They are formatted FAT16 (from the factory). The base firmware was 2.0.0. The 2.1.1 upgrade appears to have succeeded. The boot screen still says 2.0.0, but the info screen (under settings) says 2.1.1. I note new icons and screen flickering has disappeared so this SD card appears to be a winner. These are Corsair 60x cards.

Sense of listing compatible cardreaders

Listing compatible cardreaders seems to be pretty useless to me, as next to evry cardreader should work flawless, anyone haves any arguments against removeing that part?

  • I agree, unless people start reporting card reader problems Araneidae 18:06, 27 November 2005 (GMT)
  • I agree, I removed the useless lines Cloud
  • I disagree, There are few card readers out there that will read the newer 4Gb cards, even though Firmware 2 can handle them. It would be useful to see a list of that can format a 4Gb card.

Card names sorted alphabetically

For an easier search, I sorted the card names alphabetically and then by size. Keep them sorted as the list grows. Cloud

GP2x does not see files, but Windows does!

I have the following symptoms:

GP2x with firmware 1.0

SD-Card is a 1 GB Skydisk OEM/Card (66x Speed). The OEM Manufacturer is called "Team" (Taiwan).

I have formatted the card using Windows XP and I do not use a card reader.

Write speed to the card when it is formatted with FAT32: 80KB/s

Write speed to the card when it is formatted with FAT32: 160KB/s

So, very slow writing.

The gp2x does not see any files on the card!

I tried reformatting the card with Acronis Disk Director 9 to fat32.

No Change appeared.

So: Windows can read/write the SD-Card (albeit slow), but gp2x does not see anything on the card.

  • I am currently having the same problem. My card is a 1.0 GB RiDATA Card (66X). I don't have a card reader yet, and I had to disable USB 2.0 on my Windows XP machine in order to be able to use the GP2X with it. I formatted the card with FAT32 (using various methods), and I can now write & read files, but the GP2X sees nothing on the card even after re-boots. Firmware uprading naturally also doesn't work. I'm guessing that in order to remedy this situation, we'll need to obtain smaller size SD cards that are known to work, upgrade firmware, then use our 1.0 GB cards again. (2005/11/30) statikeffeck
  • Same problem exactly. I just formatted the SD card in a Windows laptop; will test to see if anything changes when I get home tonight. (2005/12/01) jjk
  • Update (2005/12/02): Yup, it works now. The Windows box didn't create a partition, which seems to have been the root of the problem. jjk

2GB card listed as compatible?

The first entry is currently "AData MyFlash Turbo SD 2GB 150X". I thought that the current firmware could only support cards up to 1GB. Stop me if I'm wrong.

The current firmware (1.4/ro) supports 4gb cards.

EDIT: please remove this, mis-read the previous page.

SanDisk 1GB

I have a sandisk 1GB which is listed as been compatible but not for firmware upgrade. I've formatted it as Fat32 and placed a custom gp2xsound.wav on the card then selected "eject". Holding down start/select and turning on the gp2x brings up the firmware updating process every time I've tried.

I have a 2GB sandisk in the mail and will give that a go once it arrives.

/*Add by Blankoworld*/

Coming from France I excuse me for any errors I could commit in this paragraph. I post here to give you a kind of solution for recognize your SD Card. I work three days under the GP2X for the sandisk card, but it didn't want to works. The solution which works was these one (I made all manipulation under UbuntUSB v4.3):

 - Insert your Sandisk Card 1 GB into the GP2X
 - Connect your GP2X with the USB Cable
 - Unmount the new peripherals which was recognized under linux with the command "umount /dev/sdc1"
 - Go to cfdisk to delete all partitions "cfdisk /dev/sdc". Be sure you write on the card in cfdisk.
 - Turn off the GP2X. Then turn on it.
 - Linux recognize your GP2X (with the submenu USB into System menu)
 - Unmount it : "unmount /dev/sdc" (just if it is mounted automatically by Linux)
 - Make a mkfs command : "mkfs.msdos -IF 32 /dev/sdc"
 - Answer the question by yes (or "oui" in french)
 - Disconnect the GP2X connection.

Then the last time you connect your GP2X, it would be mount automatically by Ubuntu (for an example), then copy all folder or file you want. Disconnect de GP2X. Goto the Explorer Utility in GP2X, you see all files or folders.

I hope it also work under your GP2X. Have fun and think you should also works, not only play ;-).

Table and list redundancy

Is it necessary to have both the table and the list afterwards? It seems a big change so I wont delete it straight away but if noone has any objections it seems redundant, confusing and a waste of space

Yes i think is redundant and can be deleted, just add the missing card name in the table. Yod4z 27/10/2006 00:26 GMT+1

no need to add 2.1.0 firmware

I think GPH has not modified the SD acces then there's no differences between 2.0.0 and 2.1.0 ;) Yod4z 28/10/2006 12H48 GMT+1

It will be much more useful for quick reference for new users if the new firmware is included. Not everyone know that 2.0.0 and 2.1.0 is the same SD-wise (which is not something that I know anything about, for example). I say it should stay.
(Gnyffel 17:35, 31 October 2006 (PST))

I agree; keeping the column would be consistent. I can also see how that chart might get unwieldy if we add every firmware release. If it works on a previous version of a major firmware release, can we assume that it will work on subsequent releases? If it doesn't work on newer firmware releases, can we assume it didn't work on older ones as well? (Again, all within the same major version.) If we make (and document) those assumptions for the chart, then it could be really simplified:

Card Compatibility
Description / Model Name Firmware 1.0 Firmware 2.0
Use Upg. Use Upg.
Test Card 1 1.4.0 1.4.0 2.0.0 2.0.0
Test Card 2 1.4.0 1.4.0 2.0.0 2.1.0
Test Card 3 2.1.0

Are regressions in support frequent enough for us to maintain that huge chart for each new firmware release?

In any case, we should either remove the partial 2.1.0 column that has been added for finish adding it. It looks dumb in its half-done state. Brainsick 03:55, 1 November 2006 (PST)

Some think like what i have done is good or not? you have just to put the first version of the firmware when it works and put the last version where it doesn't work. It can be possible to indicate the first and last version of firmeware working (exemple 1.0.0 - 2.1.0) I think GPH will not broke the compatibility with SD when improving firmware. Yod4z 01/11/2006 16H49 GMT+1

I had separated the 1.0 firmware from the 2.0 firmware because I felt that if there was going to be a regression, it would most likely be between major versions. According to the chart, there have only been two documented regressions; one for the PNY 1GB, and one for the SanDisk 1GB (normal). One happened between 1.1.0 and 1.2.0 and the other happened between 1.4.0 and 2.0.0, so it's not consistent. I don't know how much we should trust the data.

I see that you already added a new table to the page, but I was holding off on making the changes until Yono and Justthisguy had a chance to comment as they're both frequent contributors to the wiki. But, if you want to take the idea and run with it, go ahead. Brainsick 14:01, 1 November 2006 (PST)

I'm a frequent contributor too, it's me that have build the first table ;) but i think more advice is better then we wait until more advice Yod4z

Oh, absolutely; I didn't mean to exclude you. I just thought it redundant because you and I are discussing it now.  :) Brainsick 14:35, 1 November 2006 (PST)

I'm for doing it with a smaller table - if there are reported regressions, we could always just add them as footnotes or make the table like

Card Compatibility
Description / Model Name Firmware 1.0 Firmware 2.0
Use Upg. Use Upg.
Test Card 1 1.1.0 - 1.4.0 1.1.0 - 1.4.0 2.0.0 2.0.0
Test Card 2 1.4.0 1.4.0 2.0.0 (no 2.1) 2.0.0 (no 2.1)
Test Card 3 2.0.0 *1
*1 : Doesn't work with 2.1.0 or later

- several ways we might show regressions, although that may end up getting just as complicated ;)

Justthisguy 10:59, 2 November 2006 (PST)

-To avoid a huge table surely you could remove the older firmwares or put them as part of another table with a link so if the table gets to large you take the oldest firmwares and put them into a new table. The current GP2X ships with firmware 2.0 and most poeple will have upgraded to newer firmware if they already own a GP2X. Information about earlier firmware compatibilty for most people will be irelevant. Although some people may know that SD compatibilty has not changed between a firmware release few will know this and almost no one who is looking to buy a GP2X will know this. So for ease of use i think that it is best to have each firmware shown.

--tom 08:50, 14 November 2006 (PST)

GP2X does not see SD Card on first boot, does on second boot

I have a SanDisk Ultra II 4Gb SD Card, in a MkII GP2X with Firmware 2.1.1, the card has been formatted FAT32 with an SD Reader in Windows XP.

If I copy files to the SD Card, and start the GP2X, and use Games, Explorer, etc, the SD Card menus appear empty, and nothing happens if I go Settings / USB. If I flick the power off and on again, the GP2X boots, then sees the SD Card fine, and USB functions as normal.

This seems to happen when re-inserting the SD Card after having it ejected, and when the GP2X has been powered off for a period of time (5 minutes or more).

I have a normal SanDisk 1Gb card which functions perfectly, and does not have the issue described above.

The SanDisk website indicates that all current-model 4G SD Cards are SDHC, with the part number "SDSDRH-4096", however mine has the part number that corresponds with the older SD Card spec, as seen on earlier 512Mb-2Gb cards, "SDSDH-4.0". The packaging has the older SD™ logo, not the newer SDHC™, so I'm pretty confident it's not an SDHC card.

Any ideas? My first assumption is flaky firmware compatibility. Perhaps I should just get two older 2Gb cards and swap between them as required...

--Super Jamie 02:45, 8 March 2007 (PST)

Found Answer

The SD Card spec only really goes up to 2Gb. Any 4Gb non-SDHC card is not really SD-compliant, so it appears the flaky GPH firmware doesn't like to read my 4Gb card properly. It will probably work in one of the next firmware releases, or I could also just wait for Open2x to come out. Either way, I just bought a 2Gb Sandisk card, works perfectly. --Super Jamie 01:00, 25 March 2007 (PDT)

Any benefit in / need for Ultra II cards?

I've seen that SD cards labeled "Ultra II" are available for a higher price at the same storage capacity. From what I understand they are targeted at photographers who need to be able to snap many pictures in a short time and need fast read/write access. Does anyone know if GP2X users could benefit from this, particularly in the middle of gameplay or use (I'm not talking about copying a large file onto the card for the frist time)? Does the GP2X often make you wait to load or save savestates in a game, for example? GreenLion 07:06, 23 March 2007 (PDT)

  • Depends what you are playing really. If you are using the latest PicoDrive with support for zipped ISO files, then I suspect there is probably some benefit from a high-speed SD card. However, in normal operation of NES/SNES/MegaDrive/Gameboy emulators, then roms and savestates are relatively small, so wait time is negligible with a standard-speed SD card anyway. --Super Jamie 01:00, 25 March 2007 (PDT)

SanDisk's "Gaming" SD Cards

Does anyone know if there is anything about these cards that make them different from ordinary SD cards, let alone being somehow better for game purposes? Clearly they're targeted at Nintendo Wii users, given the color scheme, Wii logo, and marketing blurb, but the blurb also states that they are compatible with any SD device. GreenLion 07:19, 17 April 2007 (PDT)

Will microSD adapters work?

On amazon, they have a product like this:

It's a microSD card with an SD card adapter.

Has anyone used these? Should they work?

Should do if the SD is standard (i.e. not microSDHC) Orkie 02:30, 22 August 2007 (PDT)
Personal tools