Talk:GP2X Issues



Screen flickering

Firmware 1.1.0 combined with the CPU/LCD Tweaker utility (for firm. 1.0.1) seems to remove almost all flickering and the annoying "scanline" effect. If we all agree, the "Screen problems" section should be updated. Segata 14:26, 28 December 2005 (GMT)

Video issues

I read this quoted in the video problems section: "Some people are skeptical that WMV support will happen as WMV support under Linux is naturally less then ideal, and WMV support on non-x86 versions of Linux is all but non-existent."

WMV 1/2 (but not 3) is supported in Linux with VLC media player. Hopefully if this were to be ported the GP2X would support a lot of video and audio codecs

I have divx6 running without any problems at my gp2x, but others complained it dosnt work, wierd. divx6 encodet test movie.

USB under Linux/MacOS X

I had problems last night under both Linux and MacOS X seemingly because they misidentified the GP2X as a USB-2 device, then failed to configure it properly. Removing EHCI support from Linux fixed this and allowed me to mount it as a USB-1 device, but no idea how to do that under MacOS.

Could this be an issue with the cable, even if the device was noticed (and usable at the lower speeds)?

I don't know how to get os x to treat it as a usb 1 device other than connecting it through a usb 1 hub. If I connect mine through the usb 1 hub in my keyboard it works fine with os x. Connect it directly to the usb 2 port on the back of my mac mini and nothing happens. --Xyz 16:30, 25 November 2005 (GMT)

I have now got everything working nicely with OSX by first buying an SD card and a card reader and using the card reader to transfer a file onto the card (in fact, I just typed `touch /Volumes/NO\ NAME/something` on the terminal). Now it works and appears as a USB device when expected. --Araneidae 16:11, 26 November 2005 (GMT)

I am losing the will to carry on here. I have now lost the USB again, and I get the message "Unknown device (did not respond to inquiry)" in USB Prober when connecting the GP2X. I tried formatting the SD card (in a card reader) as "MSDOS" in Disk Utility, in an attempt to get it recognised so I can update the flash. Unfortunately this seems to have been a major step backwards. --Araneidae 23:43, 26 November 2005 (GMT)

Illume Usb Error Message

I can not get usb working for my gp2x on two computers, with three different cables. Other usb devices work on these. On my first linux computer, I get no messages at all. On my other computer I get the errors below with winXP and with knoppix linux.

Hopefully this will be useful if someone is interested in debugging.

This is the error I get from usbmon about the gp2x.


Device has problem!!! Problem Code 0xa. Please open the Device Manager for more information.

Device Description: USB Mass Storage Device
Hardware IDs: USB\Vid_0525&Pid_a4a5&Rev_0229, USB\Vid_0525&Pid_a4a5
Compatible IDs: USB\Class_08&SubClass_06&Prot_50, USB\Class_08&SubClass_06, USB\Class_08
Service (device driver): USBSTOR
Device Class: USB
Device Class GUID: {36FC9E60-C465-11CF-8056-444553540000}
Driver Entry: {36FC9E60-C465-11CF-8056-444553540000}\0019
Manufacturer: Compatible USB storage device
Location Information: File-backed Storage Gadget
PDO Name: \Device\USBPDO-4
UI Number: 
Bus Type GUID: {9d7debbc-c85d-11d1-9eb4-006008c3a19a}
Legacy Bus Type: PNPBus
Bus Number: 0x0
Enumerator: USB
Address: 0x3

Here is the error on linux.

usb 1-3: new high speed USB device using ehci_hcd and address 3
usb 1-3: khubd timed out on ep0out
usb 1-3: can't set config #1, error -110
usb 1-3: new high speed USB device using ehci_hcd and address 5
usb 1-3: khubd timed out on ep0out
usb 1-3: can't set config #1, error -110
usb 1-3: new high speed USB device using ehci_hcd and address 7
usb 1-3: khubd timed out on ep0out
usb 1-3: can't set config #1, error -110
The linux error shown is exactly the one I commented on above, so try removing the "ehci-hcd" module and see if you still get the problem.

Battery indicator

Has anyone had any trouble with the battery indicator on the bottom of their GP2X? I've never seen mine illuminated, although I've run out of battery several times. (The indicator to the right of "gamepark holdings). Sorry if this has already been mentioned... -- Joephish

Positive. No trouble, because it does nothing. The Battery state menu seems to be quite correct, though. Maybe it's not implemented yet (v1.2.1 here)? -- mcr42

confirmed with v1.2.1. i read some statements that the low batt light will work with future firmware 1.4.x. -- 77

have firmware 1.40 installed on my gp2x and it doesn't work. I'm surprised it wasn't mentioned in the main article page, I think it's important to know how much power is left in the batteries before they're completely drained --Jansport 09:14, 12 April 2006 (PDT)

Power Consumption

I think, is should also be mentioned that the GP2X draws too much power when crashed (as stated in External power supply).

USB icon does not appear on cpu but gp2x is rcognized

In the device manager the gp2x shows up from there, but only if i use the usbmon program. I have the 1.2.1 version, I downloaded the 1.4.0 version and put it on a sd memory card. Well on the gp2x it is only shown in the utilities section, where I can only delete it....How can I get it to run on the gp2x. Then I downloaded another program called gp2x usb serial, do you think that will help any? Also here I dont know where to put to on my cpu or gp2x... Man this thing is complicated...I hope we can get it to work.

With kindest regards,


Make sure you follow the instructions for firmware upgrade exactly... First you need to have the .bin in the root of your card and update the kernel, then you need to have the .gpu and the .tar.gz in your sd root and run it from the utilities menu... it sounds like you are accidentally choosing the "Explorer" menu instead? If you absolutely cannot run the .gpu from the utilities menu, simply change the file extension to .gpe and you will be able to run it from the games menu. --Mudi 09:39, 16 March 2006 (PST)

Defective firmware or GP2X, not defective USB cable?

I've come across recently that when using the packaged USB cable (that was indeed defective) on a PSP, it works perfectly fine. Maybe it's something defective with the firmware, or maybe the gp2x itself? Other USB cables work fine. --Furyhunter 18:06, 2 May 2007 (PDT)

Personal tools